Back to overview
Downtime
Expired SSL certificate
May 10, 2024 at 03:30am UTC
Affected services
🇬🇧🇺🇸 EN
🇮🇹 IT
🇫🇷 FR
🇩🇪 DE
🇪🇸 ES
🇵🇹 🇧🇷 PT
Resolved
May 10, 2024 at 05:11am UTC
We have identified the root cause of the issue. It will be resolved within 5 minutes. Thanks for your patience!
Affected services
Created
May 10, 2024 at 03:30am UTC
We have an issue with an expired SSL certificate and are working on a slution.
Affected services